日本語プログラミング言語なでしこの公式掲示板

なでしこ1 質問

トップ 最新 新規 検索

2020-10-10 12:01:51 -土 曜-

なこったーでTL取得が上手くいかない

まんち さん

ここ最近「なこったー」でのTL取得が正しく行われなくなりました。

なでしこ:1.572
nakotter:0.43
TL取得先:https://twitter.com/pso2_emg_hour

PSO2というゲームのイベント開催時間を掲示するbotのTwitterから情報を取得・整理しデスクトップに表示するプログラムなのですが
いままでは問題なく取得できていましたが、ここ最近は下記のように最後の行にURLが割り込む形での抽出になります。

---- 取得元 ----
<12時 緊急クエスト予告>
(09時半 [予告]アニメぷそ煮コミおかわり(4~7話)※開催は9)
(10時 [予告]虚無より睨む原初の闇)
13時 [予告]猛る黒曜の暴腕
15時 [予告]虚無より睨む原初の闇
19時 [予告]ビバ・ラスベガス!
20時半 [予告]アニメぷそ煮コミおかわり(4~7話)※開催は20 #PSO2
----ここまで----

----取得内容----
text=<12時 緊急クエスト予告>
(09時半 [予告]アニメぷそ煮コミおかわり(4~7話)※開催は9)
(10時 [予告]虚無より睨む原初の闇)
13時 [予告]猛る黒曜の暴腕
15時 [予告]虚無より睨む原初の闇
19時 [予告]ビ… https://t.co/0PyXNNFKl0
----ここまで----

取得時のプログラムは、
----ここから----
*TL取得
なこったークライアントから『@pso2_emg_hour』のユーザTL取得して反復
ツイート=対象@`text`
ツイートで「時 緊急クエスト予告」の出現回数
もし それ=1なら
ツイートから「#PSO2」まで切り取ってツイートに代入
ツイートA=「」。 ツイートAの0にツイートを配列一括挿入
緊急タイトル=ツイートA\0
ツイート=「」。  ツイート=ツイートA。 ツイート\0=「」
緊急名=ツイート
ツイート行=ツイートAの要素数。 ツイートA=「」
# 取得したツイートを整理
TA=1。 TA2=0。 TA3=0
(ツイート行)回
ツイート\(TA)で「(」の出現回数
もし それ=0ならば
ツイート\(TA)で「【開催中】」の出現回数
もし それ=1ならば
TA3=TA
ツイートA\(TA2)=ツイート\(TA)
TA2=TA2+1
TA=TA+1
抜ける

違えば
「ツイートの取得ができませんでした」と言う
終わり
----ここまで----
です。(プログラムをそのままコピペしたもので、ツイート対象以下の行は抽出内容を整理するもので本質問とは関係ありません)
ツイート対象を外し生データを見てもはやり上記のように最後行付近が欠損してました。

多分ですが、ハッシュタグのリンクURLが影響を及ぼしているような気がするのですが、いままでこんなことは無かったですね…

(編集パスワード送信)

親記事

この内容(No.927)に返信

この内容(No.927)をダウンロード

この内容(No.927)のテキスト表示

子記事

934 Re:Re:Re:Re:なこったーでTL取得が上手くいかない (20-10-14)
933 Re:Re:Re:なこったーでTL取得が上手くいかない (20-10-13)
932 Re:Re:なこったーでTL取得が上手くいかない (20-10-13)
931 Re:なこったーでTL取得が上手くいかない (20-10-12)
928 Re:なこったーでTL取得が上手くいかない (20-10-12)



RSS


www.eznavi.net